Установка "мастера" на проблемное железо

Вопросы настройки и использования системы. Вопросы настройки и использования прикладного ПО.

Установка "мастера" на проблемное железо

Сообщение limberg » 28 янв 2010 14:12

Имеем ПК (11 шт) со следующими характеристиками:
Мамка:
Model P4M800-8237
North Bridge VIA P4M800 Revision 00
South Bridge VIA VT8237 Revision 00
CPU Intel(R) Celeron(R) CPU 2.40GHz
Cpu Socket Socket 478 mPGA
Видео:
Display Adapter VIA/S3G UniChrome IGP
Video Processor VIA/S3G UniChrome IGP
Video memory size 32 MBytes
Adapter DAC Type Internal

Описание проблемы:
"Мастер" не встаёт :) При начальной загрузке доходит то старта иксов (не важно в графическом режиме или в текстовом) - и .....чёрный экран
Как вариант: при загрузке в параметры даю команду xdriver=vesa, ура загрузка идёт, но после установки¸ перезагрузки - чёрный экран.
Второй вариант: после перезагрузки указываю в параметрах 3 (три) - гружусь консольно - хоть так, но работает.
Сейчас переустановится и выложу все логи какие надо (говорите) :)

в xorg.conf пробовал ставить disable "glx", вместо "openhrome" писал "vesa" - не работает
Готов изучить новые пляски с бубном...

Из всех linux'ов (ubuntu, runtu, asplinux, altlinux, free-BSD, simply linux,...)графически встала последняя мандрива, но поменять разрешение экрана так и не смог.....
"Где начало того конца, которое является этим началом?"
limberg
Advanced Newbie
Advanced Newbie
 
Сообщения: 49
Зарегистрирован: 07 дек 2009 14:54

Re: Установка "мастера" на проблемное железо

Сообщение hatred » 28 янв 2010 15:52

"Любимый" via... есть драйвера, вот только работают криво, можно исправить /etc/X11/xorg.conf заменив там Driver "что-то там" на Driver "vesa" или Driver "fbdev"
и на всяк - перегрузиться.
Прошли времена когда на элементарные вопросы можно было отвечать man <что-то там> (с) из сети
Hatred's Log Place | My GitHub repos | My Gitlab repos
Аватара пользователя
hatred
Global Moderator
Global Moderator
 
Сообщения: 1204
Зарегистрирован: 08 июн 2006 00:32
Откуда: Владивосток

Re: Установка "мастера" на проблемное железо

Сообщение limberg » 28 янв 2010 16:24

Попробывал..... не работает - доходит до загрузки иксов - зависает и черный экран если "vesa" и терминал если 'fbdev"
"Где начало того конца, которое является этим началом?"
limberg
Advanced Newbie
Advanced Newbie
 
Сообщения: 49
Зарегистрирован: 07 дек 2009 14:54

Re: Установка "мастера" на проблемное железо

Сообщение hatred » 28 янв 2010 16:49

эх, поразбираться бы
Прошли времена когда на элементарные вопросы можно было отвечать man <что-то там> (с) из сети
Hatred's Log Place | My GitHub repos | My Gitlab repos
Аватара пользователя
hatred
Global Moderator
Global Moderator
 
Сообщения: 1204
Зарегистрирован: 08 июн 2006 00:32
Откуда: Владивосток

Re: Установка "мастера" на проблемное железо

Сообщение limberg » 28 янв 2010 16:51

лично? или дистанционно....
я завтра до 15.00 в гимназии жду....

limberg@jabber.ru :)
"Где начало того конца, которое является этим началом?"
limberg
Advanced Newbie
Advanced Newbie
 
Сообщения: 49
Зарегистрирован: 07 дек 2009 14:54

Re: Установка "мастера" на проблемное железо

Сообщение hatred » 28 янв 2010 16:54

можно попробовать ещё драйвер unichrome взамен openchrome
Прошли времена когда на элементарные вопросы можно было отвечать man <что-то там> (с) из сети
Hatred's Log Place | My GitHub repos | My Gitlab repos
Аватара пользователя
hatred
Global Moderator
Global Moderator
 
Сообщения: 1204
Зарегистрирован: 08 июн 2006 00:32
Откуда: Владивосток

Re: Установка "мастера" на проблемное железо

Сообщение limberg » 28 янв 2010 17:00

сейчас на перемене попробую....:)
"Где начало того конца, которое является этим началом?"
limberg
Advanced Newbie
Advanced Newbie
 
Сообщения: 49
Зарегистрирован: 07 дек 2009 14:54

Re: Установка "мастера" на проблемное железо

Сообщение limberg » 28 янв 2010 17:25

Пробовал.... вывалился в консоль :(
"Где начало того конца, которое является этим началом?"
limberg
Advanced Newbie
Advanced Newbie
 
Сообщения: 49
Зарегистрирован: 07 дек 2009 14:54

Re: Установка "мастера" на проблемное железо

Сообщение Лимон » 29 янв 2010 11:40

Выбери драйвер по своему вкусу, с которого начнем.
И давай Xorg.log сюда...
Лимон
Full Member
Full Member
 
Сообщения: 140
Зарегистрирован: 26 июн 2009 15:11
Откуда: Владивосток

Re: Установка "мастера" на проблемное железо

Сообщение limberg » 29 янв 2010 13:18

Даю...

Section "ServerFlags"
EndSection

Section "ServerLayout"
Identifier "Minimal layout"
Screen "Screen0"
EndSection

Section "Module"
SubSection "extmod"
Option "omit xfree86-dga"
EndSubSection
EndSection

Section "Device"
Identifier "Card0|0"
Driver "unichrome"
EndSection

Section "Monitor"
DisplaySize 310 230
VertRefresh 50-160
HorizSync 30-71
Identifier "Samsung SyncMaster 793DF/793MB|0"
EndSection

Section "Screen"
DefaultDepth 24
Identifier "Screen0"
Device "Card0|0"
Monitor "Samsung SyncMaster 793DF/793MB|0"

SubSection "Display"

Modes "1280x1024" "1280x960" "1280x854" "1280x800" "1280x768" "1280x720" "1152x870" "1152x864" "1120x840" "1024x768" "1024x736" "1024x600" "960x720" "848x480" "832x624" "800x600" "720x576" "640x480"
EndSubSection
EndSection
"Где начало того конца, которое является этим началом?"
limberg
Advanced Newbie
Advanced Newbie
 
Сообщения: 49
Зарегистрирован: 07 дек 2009 14:54

Re: Установка "мастера" на проблемное железо

Сообщение Лимон » 29 янв 2010 13:26

давай log (журнал) иксов, он где-то там - /var/log/Xorg*.log
Лимон
Full Member
Full Member
 
Сообщения: 140
Зарегистрирован: 26 июн 2009 15:11
Откуда: Владивосток

Re: Установка "мастера" на проблемное железо

Сообщение limberg » 29 янв 2010 13:41

Xorg.O

X.Org X Server 1.6.5
Release Date: 2009-10-11
X Protocol Version 11, Revision 0
Build Operating System: Simply GNU/Linux 5.0.0 RC2 (Billy) i686
Current Operating System: Linux test01.gym2.local 2.6.30-std-def-alt14 #1 SMP Wed Oct 7 06:44:21 UTC 2009 i686
Build Date: 12 October 2009 08:23:12AM

Before reporting problems, check https://bugzilla.altlinux.org/
to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Fri Jan 29 13:34:26 2010
(==) Using config file: "/etc/X11/xorg.conf"
(==) ServerLayout "Minimal layout"
(**) |-->Screen "Screen0" (0)
(**) | |-->Monitor "Samsung SyncMaster 793DF/793MB|0"
(**) | |-->Device "Card0|0"
(==) Automatically adding devices
(==) Automatically enabling devices
(==) FontPath set to:
catalogue:/etc/X11/fontpath.d
(==) ModulePath set to "/usr/lib/X11/modules"
(II) Cannot locate a core pointer device.
(II) Cannot locate a core keyboard device.
(II) The server relies on HAL to provide the list of input devices.
If no devices become available, reconfigure HAL or disable AllowEmptyInput.
(II) Loader magic: 0x1bc0
(II) Module ABI versions:
X.Org ANSI C Emulation: 0.4
X.Org Video Driver: 5.0
X.Org XInput driver : 4.0
X.Org Server Extension : 2.0
(II) Loader running on linux
(++) using VT number 7

(--) PCI:*(0:1:0:0) 1106:7205:1106:7205 VIA Technologies, Inc. KM400/KN400/P4M800 [S3 UniChrome] rev 1, Mem @ 0xf4000000/67108864, 0xf8000000/16777216, BIOS @ 0x????????/65536
(II) System resource ranges:
[0] -1 0 0xffffffff - 0xffffffff (0x1) MX
[1] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[2] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[3] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[4] -1 0 0xffffffff - 0xffffffff (0x1) MX[B]
[5] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[6] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[7] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[8] -1 0 0xffffffff - 0xffffffff (0x1) MX[B]
[9] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[10] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[11] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[12] -1 0 0xffffffff - 0xffffffff (0x1) MX[B]
[13] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[14] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[15] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[16] -1 0 0xffffffff - 0xffffffff (0x1) MX[B]
[17] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[18] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[19] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[20] -1 0 0xffffffff - 0xffffffff (0x1) MX[B]
[21] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[22] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[23] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[24] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[25] -1 0 0x00000000 - 0x00000000 (0x1) IX[B]
[26] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[27] -1 0 0x00000000 - 0x00000000 (0x1) IX[B]
[28] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[29] -1 0 0x00000000 - 0x00000000 (0x1) IX[B]
[30] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[31] -1 0 0x00000000 - 0x00000000 (0x1) IX[B]
[32] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[33] -1 0 0x00000000 - 0x00000000 (0x1) IX[B]
[34] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[35] -1 0 0x00000000 - 0x00000000 (0x1) IX[B]
(II) Executed /usr/libexec/X11/drv.d/x11
(II) "extmod" will be loaded. This was enabled by default and also specified in the config file.
(II) "dbe" will be loaded by default.
(II) "glx" will be loaded by default.
(II) "dri" will be loaded by default.
(II) "dri2" will be loaded by default.
(II) LoadModule: "extmod"
(II) Loading /usr/lib/X11/modules/extensions/libextmod.so
(II) Module extmod: vendor="X.Org Foundation"
compiled for 1.6.5, module version = 1.0.0
Module class: X.Org Server Extension
ABI class: X.Org Server Extension, version 2.0
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension DPMS
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "dbe"
(II) Loading /usr/lib/X11/modules/extensions/libdbe.so
(II) Module dbe: vendor="X.Org Foundation"
compiled for 1.6.5, module version = 1.0.0
Module class: X.Org Server Extension
ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "glx"
(II) Loading /usr/lib/X11/modules/extensions/libglx.so
(II) Module glx: vendor="X.Org Foundation"
compiled for 1.6.5, module version = 1.0.0
ABI class: X.Org Server Extension, version 2.0
(==) AIGLX enabled
(II) Loading extension GLX
(II) LoadModule: "dri"
(II) Loading /usr/lib/X11/modules/extensions/libdri.so
(II) Module dri: vendor="X.Org Foundation"
compiled for 1.6.5, module version = 1.0.0
ABI class: X.Org Server Extension, version 2.0
(II) Loading extension XFree86-DRI
(II) LoadModule: "dri2"
(II) Loading /usr/lib/X11/modules/extensions/libdri2.so
(II) Module dri2: vendor="X.Org Foundation"
compiled for 1.6.5, module version = 1.1.0
ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DRI2
(II) LoadModule: "unichrome"
(WW) Warning, couldn't open module unichrome
(II) UnloadModule: "unichrome"
(EE) Failed to load module "unichrome" (module does not exist, 0)
(EE) No drivers available.

Fatal server error:
no screens found

Please consult the The X.Org Foundation support
at https://bugzilla.altlinux.org/
for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.

[b]Xorg.0.log.old


X.Org X Server 1.6.5
Release Date: 2009-10-11
X Protocol Version 11, Revision 0
Build Operating System: Simply GNU/Linux 5.0.0 RC2 (Billy) i686
Current Operating System: Linux test01.gym2.local 2.6.30-std-def-alt14 #1 SMP Wed Oct 7 06:44:21 UTC 2009 i686
Build Date: 12 October 2009 08:23:12AM

Before reporting problems, check https://bugzilla.altlinux.org/
to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Fri Jan 29 13:02:45 2010
(==) Using config file: "/etc/X11/xorg.conf"
(==) ServerLayout "Minimal layout"
(**) |-->Screen "Screen0" (0)
(**) | |-->Monitor "Samsung SyncMaster 793DF/793MB|0"
(**) | |-->Device "Card0|0"
(==) Automatically adding devices
(==) Automatically enabling devices
(==) FontPath set to:
catalogue:/etc/X11/fontpath.d
(==) ModulePath set to "/usr/lib/X11/modules"
(II) Cannot locate a core pointer device.
(II) Cannot locate a core keyboard device.
(II) The server relies on HAL to provide the list of input devices.
If no devices become available, reconfigure HAL or disable AllowEmptyInput.
(II) Loader magic: 0x1bc0
(II) Module ABI versions:
X.Org ANSI C Emulation: 0.4
X.Org Video Driver: 5.0
X.Org XInput driver : 4.0
X.Org Server Extension : 2.0
(II) Loader running on linux
(++) using VT number 7

(--) PCI:*(0:1:0:0) 1106:7205:1106:7205 VIA Technologies, Inc. KM400/KN400/P4M800 [S3 UniChrome] rev 1, Mem @ 0xf4000000/67108864, 0xf8000000/16777216, BIOS @ 0x????????/65536
(II) System resource ranges:
[0] -1 0 0xffffffff - 0xffffffff (0x1) MX[B]
[1] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[2] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[3] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[4] -1 0 0xffffffff - 0xffffffff (0x1) MX[B]
[5] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[6] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[7] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[8] -1 0 0xffffffff - 0xffffffff (0x1) MX[B]
[9] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[10] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[11] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[12] -1 0 0xffffffff - 0xffffffff (0x1) MX[B]
[13] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[14] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[15] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[16] -1 0 0xffffffff - 0xffffffff (0x1) MX[B]
[17] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[18] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[19] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[20] -1 0 0xffffffff - 0xffffffff (0x1) MX[B]
[21] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[22] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[23] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[24] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[25] -1 0 0x00000000 - 0x00000000 (0x1) IX[B]
[26] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[27] -1 0 0x00000000 - 0x00000000 (0x1) IX[B]
[28] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[29] -1 0 0x00000000 - 0x00000000 (0x1) IX[B]
[30] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[31] -1 0 0x00000000 - 0x00000000 (0x1) IX[B]
[32] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[33] -1 0 0x00000000 - 0x00000000 (0x1) IX[B]
[34] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[35] -1 0 0x00000000 - 0x00000000 (0x1) IX[B]
(II) Executed /usr/libexec/X11/drv.d/x11
(II) "extmod" will be loaded. This was enabled by default and also specified in the config file.
(II) "dbe" will be loaded by default.
(II) "glx" will be loaded by default.
(II) "dri" will be loaded by default.
(II) "dri2" will be loaded by default.
(II) LoadModule: "extmod"
(II) Loading /usr/lib/X11/modules/extensions/libextmod.so
(II) Module extmod: vendor="X.Org Foundation"
compiled for 1.6.5, module version = 1.0.0
Module class: X.Org Server Extension
ABI class: X.Org Server Extension, version 2.0
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension DPMS
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "dbe"
(II) Loading /usr/lib/X11/modules/extensions/libdbe.so
(II) Module dbe: vendor="X.Org Foundation"
compiled for 1.6.5, module version = 1.0.0
Module class: X.Org Server Extension
ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "glx"
(II) Loading /usr/lib/X11/modules/extensions/libglx.so
(II) Module glx: vendor="X.Org Foundation"
compiled for 1.6.5, module version = 1.0.0
ABI class: X.Org Server Extension, version 2.0
(==) AIGLX enabled
(II) Loading extension GLX
(II) LoadModule: "dri"
(II) Loading /usr/lib/X11/modules/extensions/libdri.so
(II) Module dri: vendor="X.Org Foundation"
compiled for 1.6.5, module version = 1.0.0
ABI class: X.Org Server Extension, version 2.0
(II) Loading extension XFree86-DRI
(II) LoadModule: "dri2"
(II) Loading /usr/lib/X11/modules/extensions/libdri2.so
(II) Module dri2: vendor="X.Org Foundation"
compiled for 1.6.5, module version = 1.1.0
ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DRI2
(II) LoadModule: "unichrome"
(WW) Warning, couldn't open module unichrome
(II) UnloadModule: "unichrome"
(EE) Failed to load module "unichrome" (module does not exist, 0)
(EE) No drivers available.

Fatal server error:
no screens found

Please consult the The X.Org Foundation support
at https://bugzilla.altlinux.org/
for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.
"Где начало того конца, которое является этим началом?"
limberg
Advanced Newbie
Advanced Newbie
 
Сообщения: 49
Зарегистрирован: 07 дек 2009 14:54

Re: Установка "мастера" на проблемное железо

Сообщение Лимон » 29 янв 2010 14:35

Вот проблема:
Код: Выделить всё
(II) LoadModule: "unichrome"
(WW) Warning, couldn't open module unichrome
(II) UnloadModule: "unichrome"
(EE) Failed to load module "unichrome" (module does not exist, 0)
(EE) No drivers available.

Вот здесь ошибка:
Код: Выделить всё
Section "Device"
Identifier "Card0|0"
Driver "unichrome"
EndSection

unichrome нет. для openchome и unichome имя драйвера одинаковое - via.
надо так:
Код: Выделить всё
Section "Device"
Identifier "Card0|0"
Driver "via"
EndSection

если не заработает, новый лог показывай.
Лимон
Full Member
Full Member
 
Сообщения: 140
Зарегистрирован: 26 июн 2009 15:11
Откуда: Владивосток

Re: Установка "мастера" на проблемное железо

Сообщение limberg » 29 янв 2010 15:19

Xorg.0.log

X.Org X Server 1.6.5
Release Date: 2009-10-11
X Protocol Version 11, Revision 0
Build Operating System: Simply GNU/Linux 5.0.0 RC2 (Billy) i686
Current Operating System: Linux test01.gym2.local 2.6.30-std-def-alt14 #1 SMP Wed Oct 7 06:44:21 UTC 2009 i686
Build Date: 12 October 2009 08:23:12AM

Before reporting problems, check https://bugzilla.altlinux.org/
to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Fri Jan 29 15:12:27 2010
(==) Using config file: "/etc/X11/xorg.conf"
(==) ServerLayout "Minimal layout"
(**) |-->Screen "Screen0" (0)
(**) | |-->Monitor "Samsung SyncMaster 793DF/793MB|0"
(**) | |-->Device "Card0|0"
(==) Automatically adding devices
(==) Automatically enabling devices
(==) FontPath set to:
catalogue:/etc/X11/fontpath.d
(==) ModulePath set to "/usr/lib/X11/modules"
(II) Cannot locate a core pointer device.
(II) Cannot locate a core keyboard device.
(II) The server relies on HAL to provide the list of input devices.
If no devices become available, reconfigure HAL or disable AllowEmptyInput.
(II) Loader magic: 0x1bc0
(II) Module ABI versions:
X.Org ANSI C Emulation: 0.4
X.Org Video Driver: 5.0
X.Org XInput driver : 4.0
X.Org Server Extension : 2.0
(II) Loader running on linux
(++) using VT number 7

(--) PCI:*(0:1:0:0) 1106:7205:1106:7205 VIA Technologies, Inc. KM400/KN400/P4M800 [S3 UniChrome] rev 1, Mem @ 0xf4000000/67108864, 0xf8000000/16777216, BIOS @ 0x????????/65536
(II) System resource ranges:
[0] -1 0 0xffffffff - 0xffffffff (0x1) MX[B]
[1] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[2] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[3] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[4] -1 0 0xffffffff - 0xffffffff (0x1) MX[B]
[5] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[6] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[7] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[8] -1 0 0xffffffff - 0xffffffff (0x1) MX[B]
[9] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[10] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[11] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[12] -1 0 0xffffffff - 0xffffffff (0x1) MX[B]
[13] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[14] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[15] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[16] -1 0 0xffffffff - 0xffffffff (0x1) MX[B]
[17] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[18] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[19] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[20] -1 0 0xffffffff - 0xffffffff (0x1) MX[B]
[21] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[22] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[23] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[24] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[25] -1 0 0x00000000 - 0x00000000 (0x1) IX[B]
[26] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[27] -1 0 0x00000000 - 0x00000000 (0x1) IX[B]
[28] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[29] -1 0 0x00000000 - 0x00000000 (0x1) IX[B]
[30] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[31] -1 0 0x00000000 - 0x00000000 (0x1) IX[B]
[32] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[33] -1 0 0x00000000 - 0x00000000 (0x1) IX[B]
[34] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[35] -1 0 0x00000000 - 0x00000000 (0x1) IX[B]
(II) Executed /usr/libexec/X11/drv.d/x11
(II) "extmod" will be loaded. This was enabled by default and also specified in the config file.
(II) "dbe" will be loaded by default.
(II) "glx" will be loaded by default.
(II) "dri" will be loaded by default.
(II) "dri2" will be loaded by default.
(II) LoadModule: "extmod"
(II) Loading /usr/lib/X11/modules/extensions/libextmod.so
(II) Module extmod: vendor="X.Org Foundation"
compiled for 1.6.5, module version = 1.0.0
Module class: X.Org Server Extension
ABI class: X.Org Server Extension, version 2.0
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension DPMS
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "dbe"
(II) Loading /usr/lib/X11/modules/extensions/libdbe.so
(II) Module dbe: vendor="X.Org Foundation"
compiled for 1.6.5, module version = 1.0.0
Module class: X.Org Server Extension
ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "glx"
(II) Loading /usr/lib/X11/modules/extensions/libglx.so
(II) Module glx: vendor="X.Org Foundation"
compiled for 1.6.5, module version = 1.0.0
ABI class: X.Org Server Extension, version 2.0
(==) AIGLX enabled
(II) Loading extension GLX
(II) LoadModule: "dri"
(II) Loading /usr/lib/X11/modules/extensions/libdri.so
(II) Module dri: vendor="X.Org Foundation"
compiled for 1.6.5, module version = 1.0.0
ABI class: X.Org Server Extension, version 2.0
(II) Loading extension XFree86-DRI
(II) LoadModule: "dri2"
(II) Loading /usr/lib/X11/modules/extensions/libdri2.so
(II) Module dri2: vendor="X.Org Foundation"
compiled for 1.6.5, module version = 1.1.0
ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DRI2
(II) LoadModule: "via"
(WW) Warning, couldn't open module via
(II) UnloadModule: "via"
(EE) Failed to load module "via" (module does not exist, 0)
(EE) No drivers available.

Fatal server error:
no screens found

Please consult the The X.Org Foundation support
at https://bugzilla.altlinux.org/
for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.

Xorg.0.log.old

X.Org X Server 1.6.5
Release Date: 2009-10-11
X Protocol Version 11, Revision 0
Build Operating System: Simply GNU/Linux 5.0.0 RC2 (Billy) i686
Current Operating System: Linux test01.gym2.local 2.6.30-std-def-alt14 #1 SMP Wed Oct 7 06:44:21 UTC 2009 i686
Build Date: 12 October 2009 08:23:12AM

Before reporting problems, check https://bugzilla.altlinux.org/
to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Fri Jan 29 15:00:31 2010
(==) Using config file: "/etc/X11/xorg.conf"
(==) ServerLayout "Minimal layout"
(**) |-->Screen "Screen0" (0)
(**) | |-->Monitor "Samsung SyncMaster 793DF/793MB|0"
(**) | |-->Device "Card0|0"
(==) Automatically adding devices
(==) Automatically enabling devices
(==) FontPath set to:
catalogue:/etc/X11/fontpath.d
(==) ModulePath set to "/usr/lib/X11/modules"
(II) Cannot locate a core pointer device.
(II) Cannot locate a core keyboard device.
(II) The server relies on HAL to provide the list of input devices.
If no devices become available, reconfigure HAL or disable AllowEmptyInput.
(II) Loader magic: 0x1bc0
(II) Module ABI versions:
X.Org ANSI C Emulation: 0.4
X.Org Video Driver: 5.0
X.Org XInput driver : 4.0
X.Org Server Extension : 2.0
(II) Loader running on linux
(++) using VT number 7

(--) PCI:*(0:1:0:0) 1106:7205:1106:7205 VIA Technologies, Inc. KM400/KN400/P4M800 [S3 UniChrome] rev 1, Mem @ 0xf4000000/67108864, 0xf8000000/16777216, BIOS @ 0x????????/65536
(II) System resource ranges:
[0] -1 0 0xffffffff - 0xffffffff (0x1) MX[B]
[1] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[2] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[3] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[4] -1 0 0xffffffff - 0xffffffff (0x1) MX[B]
[5] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[6] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[7] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[8] -1 0 0xffffffff - 0xffffffff (0x1) MX[B]
[9] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[10] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[11] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[12] -1 0 0xffffffff - 0xffffffff (0x1) MX[B]
[13] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[14] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[15] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[16] -1 0 0xffffffff - 0xffffffff (0x1) MX[B]
[17] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[18] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[19] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[20] -1 0 0xffffffff - 0xffffffff (0x1) MX[B]
[21] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[22] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[23] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[24] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[25] -1 0 0x00000000 - 0x00000000 (0x1) IX[B]
[26] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[27] -1 0 0x00000000 - 0x00000000 (0x1) IX[B]
[28] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[29] -1 0 0x00000000 - 0x00000000 (0x1) IX[B]
[30] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[31] -1 0 0x00000000 - 0x00000000 (0x1) IX[B]
[32] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[33] -1 0 0x00000000 - 0x00000000 (0x1) IX[B]
[34] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[35] -1 0 0x00000000 - 0x00000000 (0x1) IX[B]
(II) Executed /usr/libexec/X11/drv.d/x11
(II) "extmod" will be loaded. This was enabled by default and also specified in the config file.
(II) "dbe" will be loaded by default.
(II) "glx" will be loaded by default.
(II) "dri" will be loaded by default.
(II) "dri2" will be loaded by default.
(II) LoadModule: "extmod"
(II) Loading /usr/lib/X11/modules/extensions/libextmod.so
(II) Module extmod: vendor="X.Org Foundation"
compiled for 1.6.5, module version = 1.0.0
Module class: X.Org Server Extension
ABI class: X.Org Server Extension, version 2.0
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension DPMS
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "dbe"
(II) Loading /usr/lib/X11/modules/extensions/libdbe.so
(II) Module dbe: vendor="X.Org Foundation"
compiled for 1.6.5, module version = 1.0.0
Module class: X.Org Server Extension
ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "glx"
(II) Loading /usr/lib/X11/modules/extensions/libglx.so
(II) Module glx: vendor="X.Org Foundation"
compiled for 1.6.5, module version = 1.0.0
ABI class: X.Org Server Extension, version 2.0
(==) AIGLX enabled
(II) Loading extension GLX
(II) LoadModule: "dri"
(II) Loading /usr/lib/X11/modules/extensions/libdri.so
(II) Module dri: vendor="X.Org Foundation"
compiled for 1.6.5, module version = 1.0.0
ABI class: X.Org Server Extension, version 2.0
(II) Loading extension XFree86-DRI
(II) LoadModule: "dri2"
(II) Loading /usr/lib/X11/modules/extensions/libdri2.so
(II) Module dri2: vendor="X.Org Foundation"
compiled for 1.6.5, module version = 1.1.0
ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DRI2
(II) LoadModule: "via"
(WW) Warning, couldn't open module via
(II) UnloadModule: "via"
(EE) Failed to load module "via" (module does not exist, 0)
(EE) No drivers available.

Fatal server error:
no screens found

Please consult the The X.Org Foundation support
at https://bugzilla.altlinux.org/
for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.

xorg.conf
Section "ServerFlags"
EndSection

Section "ServerLayout"
Identifier "Minimal layout"
Screen "Screen0"
EndSection

Section "Module"
SubSection "extmod"
Option "omit xfree86-dga"
EndSubSection
EndSection

Section "Device"
Identifier "Card0|0"
Driver "via"
EndSection

Section "Monitor"
DisplaySize 310 230
VertRefresh 50-160
HorizSync 30-71
Identifier "Samsung SyncMaster 793DF/793MB|0"
EndSection

Section "Screen"
DefaultDepth 24
Identifier "Screen0"
Device "Card0|0"
Monitor "Samsung SyncMaster 793DF/793MB|0"

SubSection "Display"

Modes "1280x1024" "1280x960" "1280x854" "1280x800" "1280x768" "1280x720" "1152x870" "1152x864" "1120x840" "1024x768" "1024x736" "1024x600" "960x720" "848x480" "832x624" "800x600" "720x576" "640x480"
EndSubSection
EndSection
"Где начало того конца, которое является этим началом?"
limberg
Advanced Newbie
Advanced Newbie
 
Сообщения: 49
Зарегистрирован: 07 дек 2009 14:54

Re: Установка "мастера" на проблемное железо

Сообщение hatred » 29 янв 2010 15:30

rpm -qa | grep 'chrome'

и да, согдасно man via:
via is a wrapper driver for the unichrome Xorg driver for VIA Unichrome integrated graphics.


и man openchrome (при установленном unichrome):
openchrome is a wrapper driver for the unichrome Xorg driver for VIA Unichrome integrated graphics.


а сам драйвер, при наличии может указывается и как unichrome, если нету - значит не установлен. Для openchrome нужно указывать только openchrome (нету там враппера в виде via)

а если указать openchrome? какие ошибки сыпятся?
Прошли времена когда на элементарные вопросы можно было отвечать man <что-то там> (с) из сети
Hatred's Log Place | My GitHub repos | My Gitlab repos
Аватара пользователя
hatred
Global Moderator
Global Moderator
 
Сообщения: 1204
Зарегистрирован: 08 июн 2006 00:32
Откуда: Владивосток

След.

Вернуться в Linux в школе

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 1

cron